Requirements

Required libraries

  • dynamicreports
  • java 1.6 or above
  • jasperreports 6.2.0
  • commons-beanutils 1.9.0
  • commons-logging 1.1.1
  • commons-collections 3.2.1
  • commons-digester 2.1
  • commons-code 1.5
  • xml-apis 1.3.04
  • xml-apis-ext 1.3.04
  • ecj 4.3.1
  • jfreechart 1.0.19
  • jcommon 1.0.23
  • commons-lang3 3.1
  • jackson-core 2.1.4
  • jackson-databind 2.1.4
  • jackson-annotations 2.1.4
  • log4j 1.2.14
  • velocity 1.7 (requires commons-lang 2.5)

Required libraries for barcodes

  • barcode4j 2.0
  • barbecue 1.5-beta1
  • core 2.3.0
  • avalon-framework-impl 4.2.0
  • batik-anim 1.7
  • batik-awt-util 1.7
  • batik-bridge 1.7
  • batik-css 1.7
  • batik-dom 1.7
  • batik-ext 1.7
  • batik-gvt-1.7
  • batik-parser 1.7
  • batik-script 1.7
  • batik-svg-dom 1.7
  • batik-util 1.7
  • batik-xml 1.7

Required libraries for exporting

  • PDF itext 2.1.7.js4
  • Excel jxl 2.6.10, poi 3.10.1

Optional

  • bcprov-jdk14 138
  • spring-core 2.5
  • spring-beans 2.5
  • hsqldb 1.8.0.10
  • xalan 2.7.1
  • serializer 2.7.1

Latest News

  • Thu
    Feb
    11
    Changes in version 4.1.0 upgrade to JasperReports 6.2.0 xyList component, see ComponentsReport for an example
  • Wed
    Nov
    18
    Changes in version 4.0.2 upgrade to JasperReports 6.1.1 added support for QR Code barcode, see BarcodeReport for a...
  • Mon
    Aug
    03
    Changes in version 4.0.1 upgrade to JasperReports 6.1.0 downgrade to iText 2.1.7 in pdf exporter horizontal/verti...





Webhosting sponsored by WebSupport.sk